Wir freuen uns, TalkING. nun in einer rundum erneuerten Form zu Verfügung stellen zu können. An einigen Stellen wird noch fleißig gearbeitet. Um die Ausfallzeit für euch jedoch so kurz wie möglich zu gestalten, fiel die Entscheidung, euch die Grundfunktionalität schon jetzt zu Verfügung zu stellen.

eduroam mit Arch Linux und netctl

Tummelplatz für Computernutzer im allgemeinen und ihrer vielfältigen Probleme

Moderator: (M) Mod.-Team Global

Antworten
woolmounter
TalkING. Newbie
TalkING. Newbie
Beiträge: 1
Registriert: Fr, 04. Jul. 14, 13:31

eduroam mit Arch Linux und netctl

Beitrag von woolmounter » Fr, 04. Jul. 14, 14:10

Hallo,

ich benutze Arch Linux und den Network Manager netctl, welcher momentan der native Network Manager von Arch Linux ist (vorher war das glaube ich netcfg). Da ich es nach einigem Hin und Her mittlerweile geschafft habe, eine entsprechende config Datei so zu gestalten, dass ich Zugang zum eduroam bekomme, wollte ich diese hier mal preisgeben. Funktioniert so bei mir an der TUHH und an der UHH.

Code: Alles auswählen

Description='eduroam for sxxx0000'
Interface=wlp3s0 (hier entsprechend euer Interface)
Connection=wireless
Security=wpa-configsection
IP=dhcp
WPAConfigSection=(
        'ssid="eduroam"'
        'proto=RSN WPA'
        'key_mgmt=WPA-EAP'
        'eap=TTLS'
        'anonymous_identity="anonymous@tu-harburg.de"'
        'identity="<sxxx0000>"'
        'password="<passwort>"'
        'priority=2'
        'ca_path="/etc/ssl/certs/"'
        'ca_path2="/etc/ssl/certs/"'
        'phase2="auth=PAP"'
&#41;
Diese config Datei z.B. als /etc/netctl/wireless-eduroam abspeichern und dann mit

Code: Alles auswählen

# netctl enable wireless-eduroam
aktivieren.

Den Namen eures wlan-Interfaces könnt ihr zum Beispiel mit

Code: Alles auswählen

$ dmesg | grep network
herausfinden.

Nicht zu vergessen die Zertifikate. Die Links zu den Zertifikaten findet ihr beim RZ beim eduroam-Bereich:
Leider bist du noch nicht berechtigt, URLs zu posten, auch nicht in
Zitaten. Dies ist ein Spamschutz. Vielen Dank für dein Verständnis!
Den Link müsst ihr euch selber raussuchen...

Wie in der config zu sehen, müssen die Zertifikate in /etc/ssl/certs/ kopiert werden. Dann habe ich noch

Code: Alles auswählen

# update-ca-certificates
ausgeführt.
Bei der ganzen Zertifikatengeschichte bin ich mir aber zugegebenermaßen nicht so sicher. Jedenfalls hat es so bei mir funktioniert :)


Möglicherweise muss das Profil noch mit

Code: Alles auswählen

# netctl start wireless-eduroam
gestartet werden.
Und dann funktioniert hoffentlich alles. Viel Erfolg und liebe Grüße,

woolmounter

PS: Falls jemand weiß, wie man ein gehashetes Passwort verwenden kann in der config und dieses nicht in plain Text dort hineinschreiben muss, wär ich sehr erfreut über die Hinweise. Was im ArchWiki steht, hat so bei mir nämlich nicht funktioniert.[/quote]

Antworten